
  

  

Laboratory 

1  
Ethernet  
A Direct Link Network with Media Access Control 

Objective 

This lab is designed to demonstrate the operation of the Ethernet network. The simulation 
in this lab will help you examine the performance of the Ethernet network under different 
scenarios. 

Overview 

The Ethernet is a working example of the more general Carrier Sense, Multiple Access 
with Collision Detect (CSMA/CD) local area network technology. The Ethernet is a 
multiple-access network, meaning that a set of nodes sends and receives frames over a 
shared link. The “carrier sense” in CSMA/CD means that all the nodes can distinguish 
between an idle and a busy link. The “collision detect” means that a node listens as it 
transmits and can therefore detect when a frame it is transmitting has interfered (collided) 
with a frame transmitted by another node. The Ethernet is said to be a 1-persistent 
protocol because an adaptor with a frame to send transmits with probability 1 whenever a 
busy line goes idle. 

In this lab you will set up an Ethernet with 14 nodes connected via a coaxial link in a bus 
topology.  The coaxial link is operating at a data rate of 10 Mbps. You will study how the 
throughput of the network is affected by the network load as well as the size of the 
packets.  
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Procedure 

Create a New Project 

To create a new project for the Ethernet network: 

1. Start OPNET IT Guru Academic Edition ⇒ Choose New from the File menu. 

2. Select Project ⇒ Click OK ⇒ Name the project <your initials>_Ethernet, and 
the scenario Coax ⇒ Click OK. 

3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty 
Scenario is selected ⇒ Click Next ⇒ Choose Office from the Network Scale list 
⇒ Click Next ⇒ Assign 200 to X Span and keep Y Span as 100 ⇒ Click Next 
twice ⇒ Click OK. 

4. Close the Object Palette dialog box. 

 

Create the Network 

To create our coaxial Ethernet network: 

1. To create the network configuration, select Topology ⇒ Rapid Configuration. 
From the drop-down menu choose Bus and click OK. 

2. Click the Select Models button in the Rapid Configuration dialog box. From the 
Model List drop-down menu choose ethcoax and click OK. 

3. In the Rapid Configuration dialog box, set the following eight values and click OK. 

 

 

 

 

 

 

 

 

 
 

Local area networks 
(LANs) are designed to 
span distances of up to a 
few thousand meters. 

The eth_tap is an 
Ethernet bus tap that 
connects a node with the 
bus. 
 
 
The eth_coax is an 
Ethernet bus that can 
connect nodes with bus  
receivers and 
transmitters via taps. 
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4. To configure the coaxial bus, right-click on the horizontal link ⇒ Select Advanced 
Edit Attributes from the menu:  

a. Click on the value of the model attribute ⇒ Select Edit from the drop-
down menu ⇒ Choose the eth_coax_adv model. 

b. Assign the value 0.05 to the delay attribute (propagation delay in sec/m). 
c. Assign 5 to the thickness attribute. 
d. Click OK. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Now you have created the network. It should look like the illustration below. 

6. Make sure to save your project. 

 

 

 

 

 

 

A higher delay is used 
here as an alternative to 
generating higher traffic 
which would require 
much longer simulation 
time. 

 
 
 

Thickness specifies the 
thickness of the line used 
to “draw” the bus link. 
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Configure the Network Nodes 

To configure the traffic generated by the nodes: 

1. Right-click on any of the 30 nodes ⇒ Select Similar Nodes. Now all nodes in the 
network are selected. 

2. Right-click on any of the 30 nodes ⇒ Edit Attributes. 

3. Check the Apply Changes to Selected Objects check box. This is important to 
avoid reconfiguring each node individually. 

4. Expand the Traffic Generation Parameters hierarchy: 

a. Change the value of the ON State Time to exponential(100) ⇒ Change 
the value of the OFF State Time to exponential(0). (Note: Packets are 
generated only in the "ON" state.) 

5. Expand the Packet Generation Arguments hierarchy: 

a. Change the value of the Packet Size attribute to constant(1024). 

b. Right-click on the Interarrival Time attribute and choose Promote 
Attribute to Higher Level. This allows us to assign multiple values to 
the Interarrival Time attribute and hence to test the network 
performance under different loads. 

 

 

 

 

 

 

 

 

 

 

 

 

6. Click OK to return back to the Project Editor. 

7. Make sure to save your project. 

The argument of the 
exponential distribution 
is the mean of the 
interval between 
successive events. In the 
exponential distribution 
the probability of 
occurrence of the next 
event by a given time is 
not at all dependent 
upon the time of 
occurrence of the last 
event or the elapsed time 
since that event. 
 
 
 
 
 
 
 
 
 
The interarrival time is 
the time between 
successive packet 
generations in the "ON" 
state. 
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Configure the Simulation 

To examine the network performance under different loads, you need to run the simulation 
several times by changing the load into the network.  There is an easy way to do that. 
Recall that we promoted the Interarrival Time attribute for package generation. Here we 
will assign different values to that attribute: 

1. Click on the Configure/Run Simulation button:  

2. Make sure that the Common tab is chosen ⇒ Assign 15 seconds to the 
Duration. 
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3. Click on the Object Attributes tab.   

4. Click on the Add button. The Add Attribute dialog box should appear filled with 
the promoted attributes of all nodes in the network (if you do not see the attributes 
in the list, close the whole project and reopen it). You need to add the Interarrival 
Time attribute for all nodes. To do that: 

a. Click on the first attribute in the list (Office  Network.node_0.Traffic 
Generation ….) ⇒ Click the Wildcard button ⇒ Click on node_0 and 
choose the asterisk (*) from the drop-down menu ⇒ Click OK. 

b. A new attribute is now generated containing the asterisk (the second one in 
the list), and you need to add it by clicking on the corresponding cell under 
the Add? column. 

c. The Add Attribute dialog box should look like the following. Click OK. 

 

 

 

 

 

 

 

 

5. Now you should see the Office Network.*.Traffic Generation Parameter …  in 
the list of simulation object attributes. Click on that attribute to select it ⇒ Click the 
Values button of the dialog box. 

6. Add the following nine values.   (Note: To add the first value, double-click on the 
first cell in the Value column ⇒ Type “exponential (2)” into the textbox and hit 
enter. Repeat this for all nine values.) 
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7. Click OK. Now look at the upper-right corner of the Simulation Configuration 
dialog box and make sure that the Number of runs in set is 9.  

 

 

 

 

 

 

 

 

 

 
 

8. For each simulation of the nine runs, we need the simulator to save a “scalar” 
value that represents the “average” load in the network and to save another 
scalar value that represents the average throughput of the network. To save 
these scalars we need to configure the simulator to save them in a file. Click on 
the Advanced tab in the Configure Simulation dialog box. 

9. Assign <your initials>_Ethernet_Coax to the Scalar file text field. 

 

 

 

 

 

 

 

 

 

 

10. Click OK and then save your project. 
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Choose the Statistics 

To choose the statistics to be collected during the simulation: 

1. Right-click anywhere in the project workspace (but not on one of the nodes or 
links) and select Choose Individual Statistics from the pop-up menu ⇒ Expand 
the Global Statistics hierarchy.  

a. Expand the Traffic Sink hierarchy ⇒ Click the check box next to Traffic 
Received (packets/sec) (make sure you select the statistic with units of 
packets/sec),  

b. Expand the Traffic Source hierarchy ⇒ Click the check box next to 
Traffic Sent (packets/sec). 

c. Click OK. 

2. Now to collect the average of the above statistics as a scalar value by the end of 
each simulation run: 

a. Select Choose Statistics (Advanced) from the Simulation menu. 

b. The Traffic Sent and Traffic Received probes should appear under the 
Global Statistic Probes. 

c. Right-click on Traffic Received probe ⇒ Edit Attributes. Set the scalar 
data attribute to enabled ⇒ Set the scalar type attribute to time 
average ⇒ Compare to the following figure and click OK. 

d. Repeat the previous step with the Traffic Sent probe. 

e. Select save from the File menu in the Probe Model window and then 
close that window.  

f. Now you are back to the Project Editor. Make sure to save your project. 

 

 

 

 

 

 

 

 

A probe represents a 
request by the user to 
collect a particular piece 
of data about a 
simulation. 
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Run the Simulation 

To run the simulation: 

1. Click on the Configure/Run Simulation button: ⇒ Make sure that 15 
second(s) (not hours) is assigned to the Duration ⇒ Click Run.  Depending on 
the speed of your processor, this may take several minutes to complete. 

2. Now the simulator is completing nine runs, one for each traffic generation 
interarrival time (representing the load into the network). Notice that each 
successive run takes longer to complete because the traffic intensity is increasing. 

3. After the nine simulation runs complete, click Close. 

4. Save your project. 

 

When you rerun the simulation, OPNET IT Guru will “append” the new results to the 
results already in the scalar file. To avoid that, delete the scalar file before you start a new 
run. (Note: Deleting the scalar file after a run will result in losing the collected results from 
that run.) 

• Go to the File menu ⇒ Select Model Files ⇒ Delete Model Files ⇒  
Select (    .os): Output Scalars ⇒ Select the scalar file to be deleted; in this lab it 
is <your initials>_Ethernet_Coax_Scalar  ⇒ Confirm the deletion by clicking 
OK  ⇒ Click Close. 
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View the Results 

To view and analyze the results: 

1. Select View Results (Advanced) from the Results menu. Now the Analysis 
Configuration tool is open.  

2. Recall that we saved the average results in a scalar file. To load this file, select 
Load Output Scalar File from the File menu ⇒ Select <your 
initials>_Ethernet-Coax from the pop-up menu. 

3. Select Create Scalar Panel from the Panels menu ⇒ Assign Traffic 
Source.Traffic Sent (packets/sec).average to Horizontal ⇒ Assign Traffic 
Sink.Traffic Received (packets/sec).average to Vertical ⇒ Click OK. 

 

 

 

 

 

4. The resulting graph should resemble the one below: 

 

 

 

 

 

 

 

 

 

 

 

 



Further Reading 
 
To familiarize yourself with the significance, physical interpretation and the actual use of various parameters 
mentioned in this laboratory, use the built-in ITGuru help feature. For example, to learn more about (node) 
Attributes → Traffic Generation Parameters → Start Time parameter, click on the respective question mark 
icon, as shown in the figure below: 
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Exercise 
 
After you have successfully executed the steps outlined on pages 1 to 10, you are expected to do the following 
three exercises: E.1 to E.3. Your deliverable for this laboratory should be a 4-5 page typed report in which you 
will provide concise answers to all questions from E.1 to E.3 and include all required screenshots of obtained 
simulation results/graphs. 
 
 
Exercise E.1 Load-Throughput Graph 
 
Explain the graph shown in page 10, which shows the relationship between the sent packets (load) and 
received packets (throughput). Why does the throughput drop when the load is either very low or very high? 
 
 
 
 
Exercise E.2 Performance (Collision Count and Throughput) Under Different Loads 
 
 

Exercise E.2.a) 
 
Modify the profile of your project  <your initials>_Ethernet, by performing the following steps: 
 

1. Click on the Configure/Run Simulation button . From the Object Attribute menu/tab delete the multiple 
value attribute (the only shown in the list). 
 
2. Right-click on any of the 30 nodes. Choose Select Similar Nodes. Now all nodes in the network are 
selected. 
 
3. Right-click on any of the 30 nodes. Choose Edit Attributes.  

 Check the Apply Changes to Selected Objects check box. This is important to avoid reconfiguring 
each node individually.

 Expand the Traffic Generation Parameters hierarchy. 
 Expand the Packet Generation Arguments hierarchy. 

a. Set the Interarrival Time attribute to exponential(0.1). 
b. Click OK twice. 

 
4. Right-click on node_0. Choose Choose Individual Statistics.  

 Expand the Ethcoax hierarchy. 
a. Click the check box next to Collision Count. 

 Expand the Traffic Source hierarchy. 
a. Click the check box next to Traffic Sent (packets/sec). 
b. Click OK. 

 
5. Right-click anywhere in the project workspace, but not on one of the nodes or links. Choose Choose 
Individual Statistics.  

 Expand the Global Statistics / Traffic Sink hierarchy. 
a. Click the check box next to Traffic Received (packets/sec). 

 Expand the Global Statistics / Traffic Source hierarchy. 
a. Click the check box next to Traffic Sent (packets/sec). 
b. Click OK. 

 
6. Save your project! 

Run the simulation by clicking on Configure/Run Simulation button , and then clicking Run.  
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View the collected results by doing the following: 
 
1. Select View Results from Results Menu. 

 Expand the Global Statistics / Traffic Source hierarchy. 
a. Click the check box next to Traffic Sent (packets/sec). 

 Expand the Global Statistics / Traffic Sink hierarchy. 
a. Click the check box next to Traffic Received (packets/sec). 

 Expand the Object Statistics / Office Network / node_0 / Traffic Source hierarchy. 
a. Click the check box next to Traffic Sent (packets/sec). 

 Expand the Object Statistics / Office Network / node_0 / Ethcoax hierarchy. 
a. Click the check box next to Collision Count. 

The resultant window and graphs should resemble the one(s) below. 
 

 
 
Make a screenshot of your own respective)results, and include them in the final report! 
 
 
Exercise E.2.b) 
Repeat the steps from Exercise E.2.a), but in Step 3 set the Interarrival Time attribute to exponential(0.05). 
Make a screenshot of obtained results, and include them in the final report! 
 
 
Exercise E.2.c) 
Repeat the steps from Exercise E.2.a), but in Step 3 set the Interarrival Time attribute to exponential(0.025). 
Make a screenshot of obtained results, and include them in the final report! 
 
 
Exercise E.2.d) 
Compare node_0’s Collision Counts from the previous three exercises (E.2.a), E.2.b), E.2.c)). What do you 
observe, and how do you explain the difference in the obtained graphs?  
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Exercise E.3 Performance under Smaller Packet Size 
 
Exercise E.3.a) 
 

Modify the profile of your project  <your initials>_Ethernet, by performing the following steps: 
 
1. Right-click on any of the 30 nodes. Choose Select Similar Nodes. Now all nodes in the network are 
selected. 
 
2. Right-click on any of the 30 nodes. Choose Edit Attributes.  

 Check the Apply Changes to Selected Objects check box. This is important to avoid reconfiguring 
each node individually. 

 Expand the Traffic Generation Parameters hierarchy. 
 Expand the Packet Generation Arguments hierarchy. 

a. Set the Packet Size attribute to constant(512). 
b. Set the Interarrival Time attribute to exponential(0.05). 
c. Click OK twice. 

 
3. Right-click on node_0. Choose Choose Individual Statistics.  

 Expand the Ethcoax hierarchy. 
a. Click the check box next to Collision Count. 

 Expand the Traffic Source hierarchy. 
c. Click the check box next to Traffic Sent (packets/sec). 
d. Click OK. 

 
4. Right-click anywhere in the project workspace, but not on one of the nodes or links. Choose Choose 
Individual Statistics.  

 Expand the Global Statistics / Traffic Sink hierarchy. 
a. Click the check box next to Traffic Received (packets/sec). 

 Expand the Global Statistics / Traffic Source hierarchy. 
c. Click the check box next to Traffic Sent (packets/sec). 
d. Click OK. 

 
5. Save your project! 

Run the simulation by clicking on Configure/Run Simulation button , and then clicking Run. Access the 
collected results by following the procedure from exercise E.2. Make a screenshot of obtained results, 
and include them in the final report! 
 
 
Exercise E.3.b) 
Compare the graphs obtained in exercise E.3.a) with those from exercise E.2.b). (In the two exercises, the 
packet interarrival times are the same, the packet sizes are different.) What do you observe, and how do you 
explain the difference in the obtained graphs?  
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