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1 Introduction

This tutorial presents an introduction to the Quartus® II CAD system. It gives a general overview of a typical CAD
flow for designing circuits that are implemented by using FPGA devices, and shows how this flow is realized in the
Quartus II software. The design process is illustrated by giving step-by-step instructions for using the Quartus II
software to implement a very simple circuit in an Altera FPGA device.

The Quartus II system includes full support for all of the popular methods of entering a description of the desired
circuit into a CAD system. This tutorial makes use of the schematic design entry method, in which the user draws
a graphical diagram of the circuit. Two other versions of this tutorial are also available, which use the Verilog and
VHDL hardware description languages, respectively.

The last step in the design process involves configuring the designed circuit in an actual FPGA device. To show
how this is done, it is assumed that the user has access to the Altera DE-series Development and Education board
connected to a computer that has Quartus II software installed. A reader who does not have access to the DE-series
board will still find the tutorial useful to learn how the FPGA programming and configuration task is performed.

The screen captures in the tutorial were obtained using the Quartus II version 12.1; if other versions of the software
are used, some of the images may be slightly different.
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2 Background

Computer Aided Design (CAD) software makes it easy to implement a desired logic circuit by using a programmable
logic device, such as a field-programmable gate array (FPGA) chip. A typical FPGA CAD flow is illustrated in
Figure 1.
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Figure 1. Typical CAD flow.

The CAD flow involves the following steps:

* Design Entry - the desired circuit is specified either by means of a schematic diagram, or by using a hardware
description language, such as Verilog or VHDL

» Synthesis — the entered design is synthesized into a circuit that consists of the logic elements (LEs) provided
in the FPGA chip

* Functional Simulation — the synthesized circuit is tested to verify its functional correctness; this simulation
does not take into account any timing issues
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* Fitting — the CAD Fitter tool determines the placement of the LEs defined in the netlist into the LEs in an
actual FPGA chip; it also chooses routing wires in the chip to make the required connections between specific
LEs

* Timing Analysis — propagation delays along the various paths in the fitted circuit are analyzed to provide an
indication of the expected performance of the circuit

* Timing Simulation — the fitted circuit is tested to verify both its functional correctness and timing

* Programming and Configuration — the designed circuit is implemented in a physical FPGA chip by pro-
gramming the configuration switches that configure the LEs and establish the required wiring connections

This tutorial introduces the basic features of the Quartus II software. It shows how the software can be used to design
and implement a circuit specified by means of a schematic diagram. It makes use of the graphical user interface to
invoke the Quartus II commands. Doing this tutorial, the reader will learn about:

* Creating a project

* Entering a schematic diagram

* Synthesizing a circuit from the schematic diagram

* Fitting a synthesized circuit into an Altera FPGA

* Assigning the circuit inputs and outputs to specific pins on the FPGA
» Simulating the designed circuit

* Programming and configuring the FPGA chip on Altera’s DE-series board

3 Getting Started

Each logic circuit, or subcircuit, being designed with Quartus II software is called a project. The software works on
one project at a time and keeps all information for that project in a single directory (folder) in the file system. To
begin a new logic circuit design, the first step is to create a directory to hold its files. To hold the design files for this
tutorial, we will use a directory introtutorial. The running example for this tutorial is a simple circuit for two-way
light control.

Start the Quartus II software. You should see a display similar to the one in Figure 2. This display consists of several
windows that provide access to all the features of Quartus II software, which the user selects with the computer
mouse. Most of the commands provided by Quartus II software can be accessed by using a set of menus that are
located below the title bar. For example, in Figure 2 clicking the left mouse button on the menu named File opens the
menu shown in Figure 3. Clicking the left mouse button on the entry Exit exits from Quartus II software. In general,
whenever the mouse is used to select something, the left button is used. Hence we will not normally specify which
button to press. In the few cases when it is necessary to use the right mouse button, it will be specified explicitly.
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Figure 2. The main Quartus II display.
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Figure 3. An example of the File menu.
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For some commands it is necessary to access two or more menus in sequence. We use the convention Menu1 >
Menu2 > Item to indicate that to select the desired command the user should first click the left mouse button on
Menu1, then within this menu click on Menu2, and then within Menu2 click on Item. For example, File > Exit
uses the mouse to exit from the system. Many commands can be invoked by clicking on an icon displayed in one of
the toolbars. To see the command associated with an icon, position the mouse over the icon and a tooltip will appear
that displays the command name.

3.1 Quartus Il Online Help

Quartus II software provides comprehensive online documentation that answers many of the questions that may arise
when using the software. The documentation is accessed from the Help menu. To get some idea of the extent of
documentation provided, it is worthwhile for the reader to browse through the Help menu.

If no web browser is specified, Quartus will complain with an error message. To specify a web browser, go to Tools
> Options... > General > Internet Connectivity. Specify a path to a web browser in the web browser field.

The user can quickly search through the Help topics by selecting Help > Search, which opens a dialog box into
which keywords can be entered. Another method, context-sensitive help, is provided for quickly finding documen-
tation for specific topics. While using most applications, pressing the F1 function key on the keyboard opens a Help
display that shows the commands available for the application.

4 Starting a New Project

To start working on a new design we first have to define a new design project. Quartus II software makes the
designer’s task easy by providing support in the form of a wizard. Create a new project as follows:

1. Select File > New Project Wizard and click Next to reach the window in Figure 4, which asks for the name
and directory of the project.

2. Set the working directory to be introtutorial; of course, you can use some other directory name of your choice
if you prefer. The project must have a name, which is usually the same as the top-level design entity that will
be included in the project. Choose light as the name for both the project and the top-level entity, as shown in
Figure 4. Press Next. Since we have not yet created the directory introtutorial, Quartus II software displays
the pop-up box in Figure 5 asking if it should create the desired directory. Click Yes, which leads to the
window in Figure 6.
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repeswe )
Directory, Name, Top-Level Entity [page 1 of 5]

What is the working directory for this project?

D:lintrotutorial
What is the name of this project?

light|
What iz the name of the topJevel design entity for this project? This name is case sensitive and must exactly match the entity name in the design file.

B B

light

|use Existing Project Settings...

[ <Back |[ mext> |[ Fnsh |[ cancel |[ Heb

Figure 4. Creation of a new project.

Figure 5. Quartus II software can create a new directory for the project.
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Add Files [page 2 of 5]

Select the design files you want to include in the project. Click Add All to add all design files in the project directory to the project.
Mote: you can always add design files to the project later.

=i )

File name: E] Add
File Name Type Library Design Entry/Synthesis Tool HDL Version Add all

Remave

Up
Down

Properties

Specify the path names of any non-default libraries.

[ < Back. ]i Next > i[ Finish ][ Cancel ][ Help

Figure 6. The wizard can include user-specified design files.

3. The wizard makes it easy to specify which existing files (if any) should be included in the project. Assuming

that we do not have any existing files, click Next, which leads to the window in Figure 7.
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s ==
Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.

Device family Show in 'Available devices' list
Family: |Cydone I A ] Package: [Any - I
Devices: |Al - Pin count: [Any " ]
Target device Speed grade: [Any T ]
() Auto device selected by the Fitter Mame filter:
@) Spedfic device selected in 'Available devices' list Show advanced devices HardCopy compatible only
Other: nfa

Available devices:

Name Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bit elements H -
EP2C35F484C7 1.2V 33216 322 483840 70 4
EP2C35F484C8 1.2V 33216 322 483840 70 4
EP2C35F48418 1.2V 33216 322
_EI
EP2C35F672C7 1.2V 33216 475 483840 70
EP2C35F672C8 1.2V 33216 475 483840 70 4
EP2C35F67213 1.2 33216 475 483840 70 4 =
e — T — - D

Companion device
HardCopy:

Limit D5P & RAM to HardCopy device resources

< Back ] [ Next > J [ Finish ] [ Cancel ] [ Help

Figure 7. Choose the device family and a specific device.

4. We have to specify the type of device in which the designed circuit will be implemented. Choose the Cyclone-
series device family for your DE-series board. We can let Quartus II software select a specific device in the
family, or we can choose the device explicitly. We will take the latter approach. From the list of available
devices, choose the appropriate device name for your DE-series board. A list of devices names on DE-series
boards can be found in Table 1. Press Next, which opens the window in Figure 8.

Board Device Name
DEO Cyclone III EP3C16F484C6
DEO-Nano | Cyclone IVE EPACE22F17C6
DE1 Cyclone 1T EP2C20F484C7
DE2 Cyclone 1T EP2C35F672C6
DE2-70 Cyclone II EP2C70F896C6
DE2-115 | Cyclone IVE EP4CE115F29C7

Table 1. DE-series FPGA device names
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EDA Tool Settings [page 4 of 5]

Specify the other EDA tools used with the Quartus II software to

D= e )

develop your project.

EDA tools:

Tool Type Tool Mame Farmat(s)

Design Entry/Synthesis <None =
<Mone > -

Formal Verification

Run Toaol Automatically
- Run this tool automatically to synthesize the current design

- Run gateevel simulation automatically after compilation

Board-Level Timing <MNone >

-

Symbel <None >
Signal Integrity

Boundary Scan

-

[ < Back H Next > H Finish ][ Cancel ][ Help

Figure 8. Other EDA tools can be specified.

5. The user can specify any third-party tools that should be used. A commonly used term for CAD software
for electronic circuits is EDA fools, where the acronym stands for Electronic Design Automation. This term
is used in Quartus II messages that refer to third-party tools, which are the tools developed and marketed by
companies other than Altera. Since we will rely solely on Quartus II tools, we will not choose any other tools.

Press Next.

6. A summary of the chosen settings appears in the screen shown in Figure 9. Press Finish, which returns to the
main Quartus II window, but with light specified as the new project, in the display title bar, as indicated in

Figure 10.
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Summary [page 5 of 5]

Project directory:

Project name:

Topevel design entity:
MNumber of files added:

Mumber of user libraries added:

Device assignments:
Family name:
Device:
EDA tools:
Design entry/synthesis:
Simulation:
Timing analysis:
Operating conditions:
Core voltage:

Junction temperature range:

s . ==

When you dick Finish, the project will be created with the following settings:

D:introtutorial
light

light

a

a

Cydone IT

EP2C35FG72C6

<Mone (<None =)
<Mone> (<None =)

0

12y

0-85°C

Next = Fsh 1| Cancel || Hep

Figure 9. Summary of project settings.
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Figure 10. The Quartus II display for a created project.

5 Design Entry Using the Graphic Editor

As a design example, we will use the two-way light controller circuit shown in Figure 11. The circuit can be used
to control a single light from either of the two switches, x; and x», where a closed switch corresponds to the logic
value 1. The truth table for the circuit is also given in the figure. Note that this is just the Exclusive-OR function of
the inputs x; and x», but we will implement it using the gates shown.

X
T D -
|

A D

— - OO
- o = o
o = = o>

X

Figure 11. The light controller circuit.

The Quartus II Graphic Editor can be used to specify a circuit in the form of a block diagram. Select File > New to
get the window in Figure 12, choose Block Diagram/Schematic File, and click OK. This opens the Graphic Editor
window. The first step is to specify a name for the file that will be created. Select File > Save As to open the pop-up
box depicted in Figure 13. In the box labeled Save as type choose Block Diagram/Schematic File (*.bdf). In the
box labeled File name type light, to match the name given in Figure 4, which was specified when the project was
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created. Put a checkmark in the box Add file to current project. Click Save, which puts the file into the directory
introtutorial and leads to the Graphic Editor window displayed in Figure 14.

12

4 Design Files

4 Memory Files

4 Verification/Debugging Files

4 QOther Files

Mew Quartus II Project

AHDL File

|Block Diagram/Schematic File
EDIF File

Qsys System File

State Machine File
SystemVerilog HOL File
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Logic Analyzer Interface File
SignalTap II Logic Analyzer File
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Block Symbol File

Chain Description File

Synopsys Design Constraints File
Text File

(

OK. ][ Cancel ][ Help ]

Figure 12. Choose to prepare a block diagram.
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Figure 13. Name the file.
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Figure 14. Graphic Editor window.

5.1 Importing Logic-Gate Symbols

The Graphic Editor provides a number of libraries which include circuit elements that can be imported into a
schematic. Double-click on the blank space in the Graphic Editor window, or click on the ' icon in the tool-
bar that looks like an AND gate. A pop-up box in Figure 15 will appear. Expand the hierarchy in the Libraries box
as shown in the figure. First expand libraries, then expand the library primitives, followed by expanding the library
logic which comprises the logic gates. Select and2, which is a two-input AND gate, and click OK. Now, the AND
gate symbol will appear in the Graphic Editor window. Using the mouse, move the symbol to a desirable location
and click to place it there. Import the second AND gate by simply moving the mouse pointer to a new position and
clicking to place another AND gate symbol there. A symbol in the Graphic Editor window can be moved by clicking
the [+ icon in the toolbar that looks like a mouse cursor, then clicking the symbol you want to move and dragging it
to a new location with the mouse button pressed. Next, select or2 from the library and import the OR gate into the
diagram. Then, select not and import two instances of the NOT gate. Rotate the NOT gates into proper position by
using the “Rotate left 90" icon 4=, Arrange the gates as shown in Figure 16.
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Libraries:
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£ and4

4
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[] tnsert symbol as block

[] Launch MegaWizard Plug-In

[ MegaWizard Plug-In Manager...

Figure 15. Choose a symbol from the library.
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Figure 16. Import the gate symbols into the Graphic Editor window.
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5.2 Importing Input and Output Symbols

Having entered the logic-gate symbols, it is now necessary to enter the symbols that represent the input and output
ports of the circuit. Use the same procedure as for importing the gates, but choose the port symbols from the library

primitives/pin. Import two instances of the input port and one instance of the output port, to obtain the image in
Figure 17.
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Figure 17. Import the input and output pins.

Assign names to the input and output symbols as follows. Make sure nothing is selected by clicking on an empty
spot in the Graphic Editor window. Point to the top input symbol and double-click the mouse. The dialog box in
Figure 18 will appear. Type the pin name, x1, and click OK. Similarly, assign the name x2 to the other input and

f to the output. Alternatively, it is possible to change the name of an element by double-clicking on the name and
typing a new one directly.
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General Format

To create multiple pins, enter a name in AHDL bus notation
(For example: "name[3..0]7), or enter a comma-seperated list of names.

Pin name(s): x|

Default value: [VCC

Figure 18. Naming of a pin.

5.3 Connecting Nodes with Wires

The symbols in the diagram have to be connected by drawing lines (wires). Click on the icon "1/ in the toolbar to
activate the Orthogonal Node Tool. Position the mouse pointer over the right edge of the x1 input pin. Click and
hold the mouse button and drag the mouse to the right until the drawn line reaches the pinstub on the top input of the
AND gate. Release the mouse button when you see a box appear, which leaves the line connecting the two pinstubs.
Next, draw a wire from the input pinstub of the leftmost NOT gate to touch the wire that was drawn above it. Note
that a dot will appear indicating a connection between the two wires.

Use the same procedure to draw the remaining wires in the circuit. If a mistake is made, a wire can be selected by
clicking on it, and removed by pressing the Delete key on the keyboard. Upon completing the diagram, click on the
%/ icon, to activate the Selection Tool. Now, changes in the appearance of the diagram can be made by selecting a
particular symbol or wire and either moving it to a different location or deleting it. The final diagram is shown in
Figure 19; save it.
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Figure 19. The completed schematic diagram.

6 Compiling the Designed Circuit

The entered schematic diagram file, light.bdf, is processed by several Quartus II tools that analyze the file, synthesize
the circuit, and generate an implementation of it for the target chip. These tools are controlled by the application
program called the Compiler.

Run the Compiler by selecting Processing > Start Compilation, or by clicking on the toolbar icon * ' that looks
like a purple triangle. Your project must be saved before compiling. As the compilation moves through various
stages, its progress is reported in a window on the left side of the Quartus II display. Successful (or unsuccessful)
compilation is indicated in a pop-up box. Acknowledge it by clicking OK, which leads to the Quartus II display in
Figure 20. In the message window, at the bottom of the figure, various messages are displayed. In case of errors,
there will be appropriate messages given.

When the compilation is finished, a compilation report is produced. A tab showing this report is opened automat-
ically, as seen in Figure 20. The tab can be closed in the normal way, and it can be opened at any time either by
selecting Processing > Compilation Report or by clicking on the icon . The report includes a number of sec-
tions listed on the left side. Figure 20 displays the Compiler Flow Summary section, which indicates that only one
logic element and three pins are needed to implement this tiny circuit on the selected FPGA chip.
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\i) 332102 Design is not fully constrained for setup regquirements
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= \Q 293000 Quartus II Full Compilation was successful. 0 errors, & warnings ™
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EL System /\_Processing (90)

179, 0 100% 00:00:19

Figure 20. Display after a successful compilation.

6.1 Errors

Quartus II software displays messages produced during compilation in the Messages window. If the block diagram
design file is correct, one of the messages will state that the compilation was successful and that there are no errors.

If the Compiler does not report zero errors, then there is at least one mistake in the schematic entry. In this case a
message corresponding to each error found will be displayed in the Messages window. Double-clicking on an error
message will highlight the offending part of the circuit in the Graphic Editor window. Similarly, the Compiler may
display some warning messages. Their details can be explored in the same way as in the case of error messages. The
user can obtain more information about a specific error or warning message by selecting the message and pressing
the F1 function key.

To see the effect of an error, open the file light.bdf. Remove the wire connecting the output of the top AND gate
to the OR gate. To do this, click on the % icon, click the mouse on the wire to be removed (to select it) and press
Delete. Compile the erroneous design by clicking on the [*icon. A pop-up box will ask if the changes made to the
light.bdf file should be saved; click Yes. After trying to compile the circuit, Quartus I software will display a pop-
up box indicating that the compilation was not successful. Acknowledge it by clicking OK. The compilation report
summary, given in Figure 21, now confirms the failed result. In the Table of Contents panel, expand the Analysis
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& Synthesis part of the report and then select Messages to have the messages displayed as shown in Figure 22.
The Compilation Report can be dispayed as a separate window as in Figure 22 by right-clicking its tab and selecting
Detach Window, and can be reattached by clicking Window > Attatch Window. Double-click on the first error
message, which states that one of the nodes is missing a source. Quartus Il software responds by displaying the
light.bdf schematic and highlighting the OR gate which is affected by the error, as shown in Figure 23. Correct the

error and recompile the design.

File Edit WView Project Assignments Processing Tools Window Help =

DEEHS ¥R 9 o

EEEETrEETETI )
—
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% Cydlone I1: EP2C35F672CE BB Flow Summary Flow Status Flow Failed - Tue Nov 06 11:52:44 2012
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/By Hierarchy | E| Fiies | ' Design Units< l’ | EH Flow OS Summary Device EP2C35FE72C6
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, IC = ] [ ] Total combinational functions M/A until Partition Merge
: |Compilation - : o - .
o o Customize Dedicated logic registers NfA until Partition Merge
Task ~ Total registers MfA until Partition Merge
|: Total pins MfA until Partition Merge
x 4 # Compie Design L Total virtual pins M/A until Partition Merge
X [> # Analysis & Synthesis Total memory bits MJA until Partition Merge
[ ¥ Fitter {Place & Route) Embedded Multiplier 9-bit elements N/ until Partition Merge
> = Assembler (Generate programm Total PLLs M/A until Partition Merge
4 n 3 < [ r
; @, B T <<Searchz> v
1 Type D Message .

0 275044 Port "IN1" of type ORZ of instance "inst4"™
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Figure 21. Compilation report for the failed design.
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Figure 22. Error messages.
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Figure 23. Identifying the location of the error.
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7 Pin Assignment

During the compilation above, the Quartus II Compiler was free to choose any pins on the selected FPGA to serve as
inputs and outputs. However, the DE-series board has hardwired connections between the FPGA pins and the other
components on the board. We will use two toggle switches, labeled SWy and SWi, to provide the external inputs, x;
and x,, to our example circuit. These switches are connected to the FPGA pins listed in Table 2. We will connect
the output f to the green light-emitting diode labeled LEDGy. Its FPGA pin assignment can also be found in Table
2.

Component DEO DEO-Nano DE1 DE2 DE2-70 DE2-115
SWy PIN_J6 | PIN_M1 | PIN_L22 | PIN_N25 | PIN_AA23 | PIN_AB28
SW PIN_HS5 | PIN_T8 | PIN_L21 | PIN_N26 | PIN_AB26 | PIN_AC28

LEDG PIN_J1 | PIN_A15 | PIN_U22 | PIN_AE22 | PIN_W27 | PIN_E21

Table 2. DE-Series Pin Assignments

File Edit View Tools Window Help 5 Search altera.com ]
<znew=> ¥ [J|Filter on node names: = « Category:|All -

tatu From To Value Enabled

1 CENEWE

Assignment Name Entity Comment Tag

__T)

LENEW == CEMEW >

0% 00:00:00

Figure 24. The Assignment Editor window.

Pin assignments are made by using the Assignment Editor. Select Assignments > Assignment Editor to reach the
window in Figure 24 (shown here as a detached window). In the Category drop-down menu select All. Click on
the <<new>> button located near the top left corner to make a new item appear in the table. Double click the box
under the column labeled To so that the Node Finder button appears. Click on the button (not the drop down
arrow) to reach the window in Figure 25. In the Filter drop-down menu select Pins: all. Then click the List button
to display the input and output pins to be assigned: f, x1, and x2. Click on x1 as the first pin to be assigned and
click the > button; this will enter x1 in the Selected Nodes box. Click OK. x1 will now appear in the box under the
column labeled To. Alternatively, the node name can be entered directly by double-clicking the box under the To
column and typing in the node name.

Follow this by double-clicking on the box to the right of this new x1 entry, in the column labeled Assignment Name.
Now, the drop-down menu in Figure 26 appears. Scroll down and select Location (Accepts wildcards/groups).
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Instead of scrolling down the menu to find the desired item, you can just type the first letter of the item in the
Assignment Name box. In this case the desired item happens to be the first item beginning with L. Finally, double-

click the box in the column labeled Value. Type the pin assignment corresponding to SWy for your DE-series board,
as listed in Table 2.

Use the same procedure to assign input x2 and output f to the appropriate pins listed in Table 2. An example using
a DE2 board is shown in Figure 27. To save the assignments made, choose File > Save. You can also simply close
the Assignment Editor window, in which case a pop-up box will ask if you want to save the changes to assignments;
click Yes. Recompile the circuit, so that it will be compiled with the correct pin assignments.

ST

Filter: [Pins: all V] [ru tomi ]

Lookin:  [light] v [ ] [¥] Include subentities

Modes Found: Selected Nodes:

Mame Assignments Mame Assignments
out f

Unassigned
in_ %1 Unassigned
in_x2 Unassigned

Figure 25. The Node Finder displays the input and output names.

Assignment Name Value Enabled Entity Comment Tag

Infer RAMs from Raw Logic (Accepts wildcards fgroups)

Input Delay from Dual-Purpose Clock Pin to Fan-Out Destinations (Accepts wildcardsfgroups)
Input Delay from Pin to Input Register (Accepts wildcards/groups)

Input Delay from Pin to Internal Cells (Accepts wildcards/groups)

Iteration limit for constant Verilog loops {Accepts wildcards/groups) i
Iteration limit for non-constant Verilog loops (Accepts u\lldcardsfgroups) | 4l
Keep synchronous clear jpreset behavior for DOIO INPUT when unmap 1/0 wysiwyg primitives (Accepts wildcardsfgroups)
Location (Accepts wildcards/groups)

Logic Cell Insertion
Manual Logic Duplication {Accepts wildcards/groups) i

Figure 26. The available assignment names for a DE-series board.
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Figure 27. The complete assignment.

The DE-series board has fixed pin assignments. Having finished one design, the user will want to use the same pin
assignment for subsequent designs. Going through the procedure described above becomes tedious if there are many
pins used in the design. A useful Quartus II feature allows the user to both export and import the pin assignments
from a special file format, rather than creating them manually using the Assignment Editor. A simple file format

that can be used for this purpose is the Quartus Il Settings File (QSF) format. The format for the file for our simple
project (on a DE2 board) is

set_location_assignment PIN_N25 -to x1
set_location_assignment PIN_N26 -to x2
set_location_assignment PIN_AE22 -to f

By adding lines to the file, any number of pin assignments can be created. Such gsf files can be imported into any
design project.

If you created a pin assignment for a particular project, you can export it for use in a different project. To see how
this is done, open again the Assignment Editor to reach the window in Figure 27. Select Assignments > Export
Assignment which leads to the window in Figure 28. Here, the file light.gsf is available for export. Click on OK. If
you now look in the directory, you will see that the file light.gsf has been created.
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Assignments to export L\\)

File name:

D:/fintrotutorial atom_netlists/light. gsf
Export assignments hierarchy path:
light
[ Export back-annotated routing
Save intermediate synthesis results
Save a nodedevel netlist of the entire design into a persistent source file

File name:

QK ][ Cancel ][ Help ]

Figure 28. Exporting the pin assignment.

You can import a pin assignment by choosing Assignments > Import Assignments. This opens the dialogue in
Figure 29 to select the file to import. Type the name of the file, including the gsf extension and the full path to the
directory that holds the file, in the File Name box and press OK. Of course, you can also browse to find the desired
file.

Specify the source and categories of assignments to import.

File name: | E Categories...

Copy existing assignments into light.gsf.bak before importing Advanced. ..

OK [ Cancel ][ Help

Figure 29. Importing the pin assignment.

For convenience when using large designs, all relevant pin assignments for the DE-series board are given in individ-
ual files. For example, the DE2 pin assignments can be found in the DE2_pin_assignments.qsf file, in the directory
tutorials\design_files, which is included on the CD-ROM that accompanies the DE-series board and can also be
found on Altera’s DE-series web pages. This file uses the names found in the DE2 User Manual. If we wanted to
make the pin assignments for our example circuit by importing this file, then we would have to use the same names
in our Block Diagram/Schematic design file; namely, SW[/0], SW[1] and LEDG/[0] for xI, x2 and f, respectively.
Since these signals are specified in the DE2_pin_assignments.qsf file as elements of vectors SW and LEDG, we must
refer to them in the same way in our design file. For example, in the DE2_pin_assignments.qsf file the 18 toggle
switches are called SW[17] to SW[0]. In a design file they can also be referred to as a vector SW[17..0].
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8 Simulating the Designed Circuit

Before implementing the designed circuit in the FPGA chip on the DE-series board, it is prudent to simulate it to
ascertain its correctness. The QSim tools can be used to simulate the behavior of a designed circuit. Before the
circuit can be simulated, it is necessary to create the desired waveforms, called fest vectors, to represent the input
signals. It is also necessary to specify which outputs, as well as possible internal points in the circuit, the designer
wishes to observe. The simulator applies the test vectors to a model of the implemented circuit and determines the
expected response. We will use the Quartus II Waveform Editor to draw the test vectors, as follows:

1. Select Start > All Programs > Altera > University Program > Simulation Tools > QSim to open the QSim

tools, which will display the window in Figure 30.

2. Select File > Open Project to display a popup window in which you can browse your directories and choose

a project file (.gpf file). Select the project you wish to simulate and click OK.

3. Generate the node finder files by selecting Processing > Generate Node Finder Files

4. From QSim, open the Waveform Editor window by selecting File > New Simulation Input File.

F& Qsim
File

Assign  Processing  Help

Naw <

Console Window

=
=
=
=
=
=
=

To
To
In

To
In

get started, open an existing Qmartus II project by selecting "File > Open Project...”
prodnce an inpunt waveform file, select "File > HNew Simmlation Inpunt".
the displayed window, create the desired input waveforms. Give it a suitable name and save it.

specify a setting for simmlation, select "Assign > Simmlation Settings".
the pop-up dialog box, choose a specific VWF file and specify either functional or timing simmlation.

>> Bun the simmlation by selecting "Processing > Start Simmlation”.

=
=

»» Warning: If you recompile your (Quartus II project with new changes, the Node Finder files may ke invalid.

»» To prewvent invalid nodes from showing up in the HNode Finder, regenerate the Node Finder files
»>» by selecting "Processing > Generate Node Finder Files", after you recompiled your project.

Version 12,1 Build 175 10/24/2012 ) Full Version

Figure 30. The QSim Window.

5. The Waveform Editor window is depicted in Figure 31. Save the file under the name light.vwf; note that this
changes the name in the displayed window. Set the desired simulation to run from 0 to 200 ns by selecting
Edit > Set End Time and entering 200 ns in the dialog box that pops up. Selecting View > Fit in Window
displays the entire simulation range of 0 to 200 ns in the window, as shown in Figure 32. You may wish to
resize the window to its maximum size.
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Figure 31. The Waveform Editor window.
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Figure 32. The augmented Waveform Editor window.

6. Next, we want to include the input and output nodes of the circuit to be simulated. Click Edit > Insert >
Insert Node or Bus to open the window in Figure 33. It is possible to type the name of a signal (pin) into the
Name box, or use the Node Finder to search your project for the signals. Click on the button labeled Node
Finder to open the window in Figure 34. The Node Finder utility has a filter used to indicate what type of
nodes are to be found. Since we are interested in input and output pins, set the filter to Pins: all. Click the
List button to find the input and output nodes as indicated on the left side of the figure.
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=
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Bus width: 1

Startindex: 0

Display gray code count as binary count

Figure 33. The Insert Node or Bus dialogue.

MNamed: = Filter: [Pins: all V] [ oK J

Lookin: = D[ List H Cancel ]

MNodes Found: Selected Nodes:
MName MName Type
F in_ %1 Input

i x1 in_ %2 Input
in out
o %2 =f Output

Figure 34. Selecting nodes to insert into the Waveform Editor.

Click on the x/ signal in the Nodes Found box in Figure 34, and then click the > sign to add it to the Selected
Nodes box on the right side of the figure. Do the same for x2 and f. Click OK to close the Node Finder window,
and then click OK in the window of Figure 33. This leaves a fully displayed Waveform Editor window, as
shown in Figure 35. If you did not select the nodes in the same order as displayed in Figure 35, it is possible
to rearrange them. To move a waveform up or down in the Waveform Editor window, click within the node’s
row (i.e. on its name, icon, or value) and release the mouse button. The waveform is now highlighted to show
the selection. Click again on the waveform and drag it up or down in the Waveform Editor.
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Figure 35. The nodes needed for simulation.

7. We will now specify the logic values to be used for the input signals x/ and x2 during simulation. The logic

values at the output f will be generated automatically by the simulator. To make it easy to draw the desired
waveforms, the Waveform Editor displays (by default) vertical guidelines and provides a drawing feature that
snaps on these lines (which can otherwise be invoked by choosing the Snap To Grid button). Observe also
a solid vertical line, which can be moved by pointing to its top and dragging it horizontally. This reference
line is used in analyzing the timing of a circuit; move it to the time = 0 position. The waveforms can be drawn
using the Selection Tool, which is activated by selecting the icon || in the toolbar.

To simulate the behavior of a large circuit, it is necessary to apply a sufficient number of input valuations
and observe the expected values of the outputs. In a large circuit the number of possible input valuations
may be huge, so in practice we choose a relatively small (but representative) sample of these input valuations.
However, for our tiny circuit we can simulate all four input valuations given in Figure 11. We will use four
50-ns time intervals to apply the four test vectors.

We can generate the desired input waveforms as follows. Click on the waveform for the x/ node. Once a
waveform is selected, the editing commands in the Waveform Editor can be used to draw the desired wave-
forms. Commands are available for setting a selected signal to 0, 1, unknown (X), high impedance (Z), weak
low (L), weak high (H), a count value (C), an arbitrary value, a random value (R), inverting its existing value
(INV), or defining a clock waveform. Each command can be activated by using the Edit > Value command,
or via the toolbar for the Waveform Editor. The Value menu can also be opened by right-clicking on a selected
waveform.

Set x/ to 0 in the time interval O to 100 ns, which is probably already set by default. Next, set x/ to 1 in the
time interval 100 to 200 ns. Do this by pressing the mouse at the start of the interval and dragging it to its end,
which highlights the selected interval, and choosing the logic value 1 in the toolbar. Make x2 = 1 from 50 to
100 ns and also from 150 to 200 ns, which corresponds to the truth table in Figure 11. This should produce
the image in Figure 36. Observe that the output f is displayed as having an unknown value at this time, which
is indicated by a hashed pattern; its value will be determined during simulation. Save the file.
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Figure 36. Setting of test values.

8.1 Performing the Simulation

A designed circuit can be simulated in two ways. The simplest way is to assume that logic elements and intercon-
nection wires in the FPGA are perfect, thus causing no delay in propagation of signals through the circuit. This is
called functional simulation. A more complex alternative is to take all propagation delays into account, which leads
to timing simulation. Typically, functional simulation is used to verify the functional correctness of a circuit as it
is being designed. This takes much less time, because the simulation can be performed simply by using the logic
expressions that define the circuit.

8.1.1 Functional Simulation

To perform the functional simulation, return to the QSim Window and select Assign > Simulation Settings... to
open the Simulation Settings window in Figure 37. Click the Browse button and select the light.vwf file you created.
Choose Functional as the simulation type, and click OK. Before running the functional simulation it is necessary to
create the required netlist, which is done by selecting Processing > Generate Simulation Netlist. A simulation

run is started by Processing > Start Simulation, or by using the icon E.. At the end of the simulation, Quartus IT
software indicates its successful completion and displays a Simulation Report illustrated in Figure 38. If your report
window does not show the entire simulation time range, click on the report window to select it and choose View >
Fit in Window. Observe that the output f is as specified in the truth table of Figure 11.
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Figure 37. Specifying the simulation type.
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Figure 38. The result of functional simulation.

8.1.2 Timing Simulation

Having ascertained that the designed circuit is functionally correct, we should now perform the timing simulation to
see how it will behave when it is actually implemented in the chosen FPGA device. Select Assign > Simulation
Settings... to get to the window in Figure 37, choose Timing as the simulation type, and click OK. Run the simulator,
which should produce the waveforms in Figure 39. Observe that there is a delay of about 6 ns in producing a change
in the signal f from the time when the input signals, x; and x», change their values. This delay is due to the
propagation delays in the logic element and the wires in the FPGA device.
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Figure 39. The result of timing simulation.

9 Programming and Configuring the FPGA Device

The FPGA device must be programmed and configured to implement the designed circuit. The required config-
uration file is generated by the Quartus II Compiler’s Assembler module. Altera’s DE-series board allows the
configuration to be done in two different ways, known as JTAG and AS modes. The configuration data is transferred
from the host computer (which runs the Quartus II software) to the board by means of a cable that connects a USB
port on the host computer to the leftmost USB connector on the board. To use this connection, it is necessary to
have the USB-Blaster driver installed. If this driver is not already installed, consult the tutorial Getting Started with
Altera’s DE-Series Boards for information about installing the driver. Before using the board, make sure that the
USB cable is properly connected and turn on the power supply switch on the board.

In the JTAG mode, the configuration data is loaded directly into the FPGA device. The acronym JTAG stands for
Joint Test Action Group. This group defined a simple way for testing digital circuits and loading data into them,
which became an IEEE standard. If the FPGA is configured in this manner, it will retain its configuration as long
as the power remains turned on. The configuration information is lost when the power is turned off. The second
possibility is to use the Active Serial (AS) mode. In this case, a configuration device that includes some flash memory
is used to store the configuration data. Quartus II software places the configuration data into the configuration device
on the DE-series board. Then, this data is loaded into the FPGA upon power-up or reconfiguration. Thus, the FPGA
need not be configured by the Quartus II software if the power is turned off and on. The choice between the two
modes is made by the RUN/PROG switch on the DE-series board. The RUN position selects the JTAG mode, while
the PROG position selects the AS mode.

9.1 JTAG Programming
The programming and configuration task is performed as follows. Flip the RUN/PROG switch into the RUN position.

Select Tools > Programmer to reach the window in Figure 40. Here it is necessary to specify the programming
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hardware and the mode that should be used. If not already chosen by default, select JTAG in the Mode box. Also,
if the USB-Blaster is not chosen by default, press the Hardware Setup... button and select the USB-Blaster in the
window that pops up, as shown in Figure 41.

N T

File Edit View Processing Tools Window Help = Search altera.com

_3. Hardware Setup... | USB-Blaster [USB-0] Mode: [JT&\G '] Progress: I

[ Enable real-time ISP to allow background programming (for MAX II and MAX V devices)

m File Device Checksum Usercode Program/ Verify Blank- Examine
Configure Chedk

output_files light.saf EP2C35F672 002F8362 FFFFFFFF

= Stop

{ Delete

‘i"_,‘ Change File...

gl save File
1 up

ﬂ,“'ﬂ Down

Figure 40. The Programmer window.

Observe that the configuration file light.sof is listed in the window in Figure 40. If the file is not already listed, then
click Add File and select it. This is a binary file produced by the Compiler’s Assembler module, which contains
the data needed to configure the FPGA device. The extension .sof stands for SRAM Object File. Click on the
Program/Configure check box, as shown in Figure 42.
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Hardware Setup

Hardware Settings JTAG Settings

Select a programming hardware setup to use when programming devices. This programming
hardware setup applies only to the current programmer window.

Currently selected hardware: [USB-BIasher [usB-0] - ]

Available hardware items

Hardware Server | Add Hardware... I

UsB-Blaster Local

Remove Hardware

Figure 41. The Hardware Setup window.

Ay Programmer - D/introtutorial/light - light - files/li (2]

Fie FEdit View Processing Tools Window Help 5 Search altera.com @

j. Hardware Setup... | USB-Blaster [USB-0] Mode: [JT&G hd Progress: ]

[ Enable real-time I5P to allow background programming (for MAX IT and MAX V devices)

W File Device Checksum Usercode Program, Verify Blank- Examine
et Start Configure Check
i stop output_files/flight.sof EP2C35F572 002F8362 FFFFFFFF
@ Auto Detect
[ Add File...
E Change File...
4 1 v

[ save File n
]
T up : ]
ﬂ‘ﬁl Down

Figure 42. The updated Programmer window.

Now, press Start in the window in Figure 42. An LED on the board will light up when the configuration data has
been downloaded successfully. If you see an error reported by Quartus II software indicating that programming
failed, then check to ensure that the board is properly powered on.

Altera Corporation - University Program 33
October 2012


http://www.altera.com/education/univ/

QUARTUS IT INTRODUCTION USING SCHEMATIC DESIGNS For Quartus 11 12.1

9.2 Active Serial Mode Programming

In this case, the configuration data has to be loaded into the configuration device on the DE-series board. Refer to
Table 3 for a list of configuration devices on DE-series boards. To specify the required configuration device select
Assignments > Device, which leads to the window in Figure 43. Click on the Device and Pin Options button
to reach the window in Figure 44. Now, click on Configuration in the menu on the left to obtain the window in
Figure 45. In the Configuration device box (which may be set to Auto) choose the correct configuration device name
and click OK. Upon returning to the window in Figure 43, click OK. Recompile the designed circuit.

Board Configuration Device
DEO EPCS4
DEO-Nano EPCS64
DE1 EPCS4
DE2 EPCS16
DE2-70 EPCS64
DE2-115 EPCS64

Table 3. DE-series Configuration Device Names

Select the family and device you want to target for compilation.
Device family Show in 'Available devices' list
Family: |Cyclone II - ] Package: [Any - ]
Devices: |Al - Pin count: [Any - l
Speed grade: [Any ']
Target device
_ Name filter:
() Auto device selected by the Fitter
e . | show ad d devi HardCopy tible only
@ Specific device selected in 'Available devices' list oW advanced devices SRS BEL AR
EirzE 3l Device and Pin Options...
Available devices:
Name Core Voltage LEs UserI/0s Memory Bits Embedded multiplier 9-bit elements  +
EP2C35F484C6 1.2V 33216 322 433840 7o
EP2C35F484C7 L2V 33216 322 433840 7o
EP2C35F484C8 L2V 33216 322 433840 7o
EP2C35F48415 1.2V 33216 322 433840 70
EPOCSF67C6 v J3sas a5 Jame o |
EP2C35F672C7 1.2V 33216 475 4833840 7o l_l
EP2C35F672C8 L2V 33216 475 433840 7o
EP2C35F67218 L2V 33216 475 433840 7o
EP2C35U484C6 1.2V 33216 322 433840 70 <
a | [ r
Migration compatibility Companion device
0 migration devices selected Limit DSP & RAM to HardCopy device resources
[ OK ] [ Cancel ] [ Help

Figure 43. The Device Settings window.
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Category:

|General
Configuration
Programming Files
Unused Pins
Dual-Purpose Pins
Capacitive Loading
Board Trace Model
1/0 Timing

Voltage

Pin Placement
Error Detection CRC
CwP Settings

, :

General

Specify general device options. These options are not dependent on the configuration scheme.

Options:

Auto-restart configuration after error

[7] Release dears before tri-states

[ Enable user-supplied start-up dodk (CLKUSR)
[ Enable device-wide reset (DEV_CLRR)

[ Enable device-wide output enable {DEV_OE)
[ Enable INIT_DONE output

[] auto usercode

JTAG user code (32-bit hexadedmal):  FFFFFFFF
In-system programming clamp state:

Delay entry to user mode:

Device initialization dock source:

Description:

Directs the device to restart the configuration process automatically if a data error is
encountered, If this option is turned off, you must externally direct the device to restart the
configuration process if an error occurs,

OK ] [ Cancel ] [ Help
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Figure 44. The Options window.
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[ ™

Category:

General
Configuration
Programming Files
Unused Pins
Dual-Purpose Pins
Capaditive Loading
Board Trace Model
1/0 Timing

Valtage

PFin Placement
Error Detection CRC
CvP Settings

Specify the device configuration scheme and the configuration device. Note: For HardCopy
designs, these settings apply to the FPGA prototype device.

Configuration scheme: [Acﬁve Serial (can use Configuration Device) - ]

Configuration mode:

Configuration device

Auto hd
Use configuration device: Auto

EPCS1
EPC54

Contiurstondeie 10 vlge: TS A —
EPCO16
Force VCCIO to be compatible { Epcg32
EPCS64

- EPCQBE4
Generate compressed bitstreams Tres1zs

Active serial dock source: EPCQ128

| »

m

Enable input tri-state on active configuration pins in user mode

Description:

Specifies the configuration device that you want to use as the means of configuring the target
device,

[ OK ][ Cancel ][ Help ]

Figure 45. Specifying the configuration device.

The rest of the procedure is similar to the one described above for the JTAG mode. Select Tools > Programmer
to reach the window in Figure 40. In the Mode box select Active Serial Programming. If you are changing the
mode from the previously used JTAG mode, the pop-up box in Figure 46 will appear, asking if you want to clear all
devices. Click Yes. Now, the Programmer window shown in Figure 47 will appear. Make sure that the Hardware
Setup indicates the USB-Blaster. If the configuration file is not already listed in the window, press Add File. The
pop-up box in Figure 48 will appear. Select the file light.pof in the directory introtutorial and click Open. As a
result, the configuration file light.pof will be listed in the window. This is a binary file produced by the Compiler’s
Assembler module, which contains the data to be loaded into the configuration device on the DE-series board.
The extension .pof stands for Programmer Object File. Upon returning to the Programmer window, click on the
Program/Configure check box, as shown in Figure 49.
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% Pregrammer - D:fintrotutorial,

File Edit View

Figure 46. Clear the previously selected devices.

Processing  Tools

ight - light - [outp

Window

les/light.cdf]

Help 5

Some devices in current device list cannot be added to selected programming mode
Active Serial Programming. Do you want to dear all devices in current device list and
switch to selected mode?

[E=E)

Search altera.com e

_?. Hardware Setup... | USB-Blaster [USB-0]

Enable real-time ISP to allow background programming (for MAX II and MAX V devices)

Mode: [Acﬁve Serial Programming +

Progress:

l

BEE
[ diswp |
[ 8 Auto Detect |

[ XoDeete |

| E‘ Change File...

File

Device

Checksum

Usercode

Program,
Configure

Verify

Blank-
Check

Examine

| [ save File |

[ thw |
| ﬂ,‘ﬂﬂ Down |

Figure 47. The Programmer window with Active Serial Programming selected.
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' seect rogrmming i S
Look in: [ | DiVintrotutorialoutput_files ,] - - I
¥ My Computer || L lioht.pof|
a gelliott

File name: |Iight.|:»<nc

Files of type: [PDF Files (*.pof)

Figure 48. Choose the configuration file.

i Programmer - D+/introtutorial/light - light - [output files/light.cdf]* E.L

Fle Edit View Processing Tools Window Help 5 Search altera.com @I

£, Hardware Setup...| USB-Blaster [USB-0] Mode: [hcﬁve Serial Programming '] Progress: [ ]

[T] Enable real-time ISP to allow background programming (for MAX 1T and MAX V devices)

Examine

m File Device Checksum Usercode Program/ Verify Blank-
Confgure Chece

b stop output_files light.pof EPCS16 1C789BAD 00000000

ﬁ Auto Detect

2 Add File...

E Change File...
4 1 v

(& save File "

[ Add Device... H

T up

ﬂ,‘ﬁl Down

Figure 49. The updated Programmer window.

Flip the RUN/PROG switch on the DE-series board to the PROG position. Press Start in the window in Figure 49.
An LED on the board will light up when the configuration data has been downloaded successfully. Also, the Progress
box in Figure 49 will indicate when the configuration and programming process is completed, as shown in Figure 50.
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% Programmer - D:fintrotutorial/light - light - [output_files/li

File Edit View Processing Tools Window Help ==|) Search altera.com

j. Hardware Setup... SB-Blaster [USB-0 Mode: [Acﬁve Serial Programming  + Progress: 100% (Successful) -

[ Enable real-time ISP to allow background programming (for MAX II and MAX V devices)

Checksum Usercode Program, Blank- Examine

W File Device

output_files light.pof EPCS16 1C739BAD 00000000 ] [} [}
@il Stop

ﬂ Auto Detect
{ Delete
b Add File....

‘i"_,‘ Change File...

gl save File
7 Add Device...
1 up
ﬂ,‘i'ﬂ Down

Figure 50. The Programmer window upon completion of programming.

10 Testing the Designed Circuit

Having downloaded the configuration data into the FPGA device, you can now test the implemented circuit. Flip
the RUN/PROG switch to RUN position. Try all four valuations of the input variables x; and xp, by setting the
corresponding states of the switches SW; and SWj. Verify that the circuit implements the truth table in Figure 11.

If you want to make changes in the designed circuit, first close the Programmer window. Then make the desired
changes in the Block Diagram/Schematic file, compile the circuit, and program the board as explained above.
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